New to Telerik UI for WPF? Download free 30-day trial

Telerik Version Distributions

The Telerik UI for WPF product provides several different sets of assemblies (distributions) built against different .NET versions. This article lists the versions used to build the Telerik dlls and in what .NET runtime versions you can use them.

.NET

Telerik Distribution Telerik Versions Supported Runtime
.NET Core 3.1 R1 2019 - present .NET Core 3.1 and later
.NET 5 R2 2020 - R3 2022 SP2 .NET 5 and later
.NET 6 R3 2021 SP1 - present .NET 6 and later
.NET 7 R3 2022 SP2 - present .NET 7, NET 8 and later

.NET Framework

Telerik Distribution Telerik Versions Supported Runtime
.NET Framework 4.0 Q2 2010 - present .NET Framework 4.0 and later
.NET Framework 4.5 Q3 2012 - present .NET Framework 4.5 and later

With the Q2 2024 release, the .NET Core 3.1, .NET Framework 4.0 and 4.5 will be deprecated, as an act to align the Telerik UI for WPF product with Microsoft's recommended framework versions. Read more about this decision in the following blog post. The minimum version in the releases after this change takes effect will be, .NET 6 for the .NET users and .NET Framework 4.6.2 for the .NET Framework users. Additionally, Microsoft documentation provides a guide for upgrading to .NET Framework 4.6.2 and later.

See Also

In this article