New to Telerik UI for WinUI? Download free 30-day trial

System Requirements

Before you start working with the Telerik UI for WinUI controls, you have to set up your WinUI project.

The following list summarizes the requirements you need to meet before you choose any of the available Telerik UI for WinUI installation approaches. For more information on getting started with the library, refer to the section with the First Steps guides.

The system requirements, which are needed for setting up your WinUI projects are:

  • Windows 10, version 1809 (build 17763) or later
  • Visual Studio 2019, version 16.9 or later with the following components:

    • The Universal Windows Platform development workload
    • The Windows 10 SDK (10.0.19041.0) individual component
    • The Windows App SDK. The supported version is 1.1.0.
  • Windows 10, version 1809 (build 17763) or later.

  • Visual Studio 2019, version 16.9 or later.

    Currently, Visual Studio 2019, version 16.9, supports part of the WinUI 3 features. To access all WinUI 3 tooling features, install Visual Studio, version 16.10 Preview.

    Include the following workloads and components:

  • A Telerik account.

For the complete instructions and additional information on setting up your development environment, check out the following Microsoft help articles:

See Also

In this article
Not finding the help you need?