System Requirements

Test Studio Dev is a Visual Studio extension and inherits all the system requirements that Visual Studio versions have. You can check the system requirements for supported versions Visual Studio 2017, Visual Studio 2015, Visual Studio 2013 or Visual Studio 2012.

User Account Control (UAC)

  • If you are using Internet Explorer for test recording, the UAC needs to be set to 'Never Notify' in corresponding Settings page.
  • Internet Explorer 11
  • Chrome latest version
  • Firefox latest version
  • Microsoft Edge (Chromium) latest version
  • Microsoft Edge (Legacy) latest version - installing latest Edge Chromium removes the Edge Legacy instance
  • Safari latest version (5.1.7)

Visual Studio requirements

  • The Test Studio Dev extension can be installed on Visual Studio 2012, 2013, 2015, 2017 and 2019 (v.16.5+) Professional or higher edition.
  • You must run Visual Studio as Administrator
  • Visual Studio projects should target .Net 4.5 or higher
  • Visual Studio 2017 requires additional Individual components on top of its default installation

Data Binding

Framework

Source Control

  • Test Studio Dev uses the built-in TFS integration in Visual Studio

Build Server / Continuous Integration

If executing via MSTest you will need

  • Visual Studio (see above requirements) with VS plugin, or

  • MSTest.exe installed on agent and controller

  • Test Studio Dev Runtime or above installed on agent

If executing via ArtOfTest.Runner

Beta Software

  • Operating systems and web browsers in the beta stage are not supported.
In this article
Not finding the help you need? Improve this article