New to Telerik UI for .NET MAUI? Start a free 30-day trial

System Requirements for Telerik UI for .NET MAUI

With Telerik .NET MAUI 3.2.0 version we have added a support for .NET 7.0

In order to develop applications with Telerik UI for .NET MAUI you need to have the following development tools installed:

Windows

  • Windows 11 and Windows 10 version 1809 or higher, using Windows UI Library (WinUI) 3.
  • Visual Studio 2022 17.3 or greater.

For .NET 7.0 projects use Visual Studio 2022 Preview

For more detailed instructions go to Install .NET MAUI in Visual Studio 2022 for Windows .

macOS

You can develop Android, iOS and macOS apps. The iOS apps will require iOS 10 and higher. WinUI apps are not supported on macOS.

  • macOS 10.15 or higher, using Mac Catalyst
  • Visual Studio 2022 for Mac 17.4 Preview. Visual Studio for Mac installer inspects your system and verifies which components are installed and which need to be updated.
  • latest version of Xcode.

For more detailed instructions go to Install .NET MAUI in Visual Studio 2022 Preview for Mac.

Supported platforms

You can use Telerik UI for .NET MAUI for application development for the following mobile operating systems:

Platform Supported version
Android 5.0 (API 21) or higher
iOS 10 or higher
macOS 10.15 or higher, using Mac Catalyst
Windows 11 and Windows 10 version 1809 or higher, using Windows UI Library (WinUI) 3

See Also

In this article
Not finding the help you need?