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Error Starting Services

Problem

While upgrading Test Studio installation I get a message like this:

Service 'Telerik Scheduling Service' (Telerik Scheduling Service) failed to start. Verify that you have sufficient privileges to start system services.

Cause

This error may appear if the default port used for the Scheduling service - 8009, is used by another application. This can be verified using the Windows Event Viewer.

Solution 1:

  1. Cancel the current Test Studio installation.

  2. Open a File Explorer and browse to: C:\ProgramData\Telerik\Configs.

  3. Locate file with name Telerik.TestStudio.ExecutionManager.exe.config and open it in a text editor app such as Notepad++.

  4. Change the port (highlighted in the image below) to another port - for example 8010. Save the changes and continue with installation.

    Change port

  5. Restart the installation.

Solution 2:

  1. Cancel the current Test Studio installation.

  2. Uninstall the old version of Test Studio through the Windows Control Panel -> Programs and Features.

  3. Open a File explorer and browse to the Progress Test Studio folder with config files C:\ProgramData\Telerik\Configs.

    Note 'ProgramData' is a Windows system folder and is hidden by default. You my need to change the Windows File Explorer settings to show all files.

  4. Locate file with name Telerik.TestStudio.ExecutionManager.exe.config and to a backup name - for example Telerik.TestStudio.ExecutionManager.exe.config.bak. This will cause the installation process to create a new config file with the default settings for the Scheduling configuration.

  5. Restart the installation.

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