Remotely Data-Bound Scheduler Does Not Populate
Environment
Product | Progress® Kendo UI® Scheduler for jQuery |
Operating System | Windows 10 64bit |
Description
A remotely data-bound jQuery Scheduler does not populate.
Cause
Such behavior may be caused by various reasons.
Solution
To diagnose the cause of the issue, open your browser developer console and check for JavaScript errors. Pressing the F12
functional key is the shortcut for most browsers to display the console. Now you can easily address all JavaScript errors:
-
Check the Network (or Net in Firebug) tab of the browser developer console. Look for a failed HTTP request for the transport operations configured via the dataSource Scheduler option.
- HTTP status code 401 indicates that an authentication is required and has failed, or not is not provided yet.
- HTTP status code 403 indicates that a request is not authorized. It is possible that the current user does not have the required permissions.
- HTTP status code 404 indicates that the requested URL cannot be found. Check if the controller and action names are spelled correctly.
- HTTP status code 500 indicates that a server error occurred while processing the request.
Check if the server response is in the correct data type format. For more information see the Binding to remote service help topic.
- Check if the models returned from the sever match the required kendo.data.SchedulerEvent fields. For more information check the Binding to remote service help topic.