Requirements

The following article lists what is required in order to be able to use the controls converter.

  • Visual Studio 2015 Update 2

  • .NET 4.6.1 - this is required if your Visual Studio does not have Update 2 installed. You can download it from here.

  • Solution that contains project with default .NET controls.

The WinForms converter crashes when converting a project with Visual Studio 2017 18.7 or newer. This is caused because in the latest version of Visual Studio a type used in the converter was moved. Additional information is available here: WinForms Converter crashes with Visual Studio 15.8 WinForms Converter is not available for VS 2019 yet because of breaking changes in Roslyn.

See Also

In this article
Not finding the help you need? Improve this article