jQuery Support

Telerik UI for ASP.NET Core is a set of server-side wrappers that wrap Kendo UI for jQuery widgets.

The Kendo UI library is based on jQuery and all Kendo UI bundles include the corresponding minified jQuery library in their js directories.

In order for the Kendo UI scripts to work as expected, include a reference to the jQuery library in the document before the scripts.

Supported Versions

The current official version of Telerik UI for ASP.NET Core requires jQuery version 1.12.4. Usually, each newly released jQuery version introduces breaking changes and is not compatible with the existing Telerik UI for ASP.NET Core versions. In such cases, use the previous jQuery version until the next official Telerik UI for ASP.NET Core version that resolves the issue is released. Normally, the jQuery version that is shipped with the Telerik UI for ASP.NET Core service packs is not changed but is updated in major releases.

The following table provides a list of the jQuery versions that are compatible with the major Telerik UI for ASP.NET Core releases and their corresponding service packs.

Major Releases jQuery Version Comments
UI for ASP.NET Core 2019.2.514 (R2 2019) 1.12.4 Also compatible with 1.10.x, 2.2.x and 3.4.1
UI for ASP.NET Core 2019.1.115 (R1 2019) 1.12.4 Also compatible with 1.10.x, 2.2.x and 3.3.1
UI for ASP.NET Core 2018.3.911 (R3 2018) 1.12.4 Also compatible with 1.10.x, 2.2.x and 3.3.1
UI for ASP.NET Core 2018.2.516 (R2 2018) 1.12.4 Also compatible with 1.10.x, 2.2.x and 3.3.1
UI for ASP.NET Core 2018.1.117 (R1 2018) 1.12.4 Also compatible with 1.10.x, 2.2.x and 3.1.1
UI for ASP.NET Core 2017.3.913 (R3 2017) 1.12.3 Also compatible with 1.10.x, 2.2.x and 3.1.1
UI for ASP.NET Core 2017.2.504 (R2 2017) 1.12.3 Also compatible with 1.10.x, 2.2.x and 3.1.1
UI for ASP.NET Core 2017.1.118 (R1 2017) 1.12.3 Also compatible with 1.10.x, 2.2.x and 3.1.1
UI for ASP.NET Core 2016.3.1118 (R3 2016 SP2) 1.12.3 Also compatible with 1.10.x, 2.2.x and 3.1.1
UI for ASP.NET Core 2016.3.914 (R3 2016) 1.12.3 Also compatible with 1.10.x and 2.2.x

Working with Earlier Versions

Occasionally, a legacy web application might require an earlier jQuery version with which Kendo UI is not compatible. In such cases, use a recent jQuery version together with the jQuery Migrate plugin. It restores the jQuery features that have been depreciated and provides for the required backward compatibility.

See Also

In this article
Not finding the help you need? Improve this article