Report Is Unavailable or Session Has Expired Error Occurs
Environment
Product | Progress® Telerik® Reporting |
Version | Q2 2012 and later |
Report Viewers | Legacy ASP.NET WebForms Viewer |
Description
The described scenario and suggested solution relate to the legacy ASP.NET WebForms ReportViewer. It is recommended that you migrate to the HTML5 ReportViewer.
An error message that the report is unavailable or that the session has expired error message occurs when using the legacy ASP.NET WebForms ReportViewer.
Cause
The legacy ASP.NET WebForms ReportViewer depends on the ASP.NET Session.
Solution
If the session expires, refresh the page with the legacy ASP.NET WebForms viewer.