HTML5 Report Viewer throws 405 Error
Environment
| Product | Progress® Telerik® Reporting |
Description
Upon navigating to the page with the report viewer, the below error is thrown.
Error Message
Failed to load resource: the server responded with a status of 405 (Method Not Allowed)
Possible Causes
- The
WebDavModuleis used by IIS. The Telerik Reporting REST service requiresPUTandDELETEverbs. Those verbs might be blocked by theWebDavModule. - The
Get Clients Session Timeout Secondsendpoint is failing with a status code of 405(Method Not Allowed) due to a greedy route in the routes configuration.
Solutions
Solution 1
To resolve the issue with theWebDavModule, it may be removed from the configuration of the web application (e.g. Web.config)as shown in the following example:
<configuration>
<system.webServer>
<modules runAllManagedModulesForAllRequests="true">
<remove name="WebDAVModule"/>
</modules>
</system.webServer>
</configuration>
Solution 2
To resolve the problem when the Get Clients Session Timeout Seconds failing, move the registration of the reporting routes before the default ones, for example:
Telerik.Reporting.Services.WebApi.ReportsControllerConfiguration.RegisterRoutes(config);
config.Routes.MapHttpRoute(
name: "DefaultApi",
routeTemplate: "api/{controller}/{action}/{id}",
defaults: new { id = RouteParameter.Optional }
);