Client ID Is Not Found or Has Expired Error Occurs
Environment
Product | Progress® Telerik® Reporting |
Version | Q2 2012 and later |
Report Viewers | Viewers working with the Telerik Reporting REST services |
Description
An Error Client with ID 'xxxxxx-xxxx' not found. Expired.
occurs when using the HTML5 Telerik Reporting ReportViewer.
Cause
The error message indicates that the ID of the Report Viewer cannot be found in the cache storage.
Solution
To solve this issue, use the following approaches:
Check if the time set as the
ClientSessionTimeout
of the Reporting REST service has expired.Alternatively, fix the
Storage
of the Reporting REST service, if it is not set according to the hosting environment.