AngularJS Support

As of the Kendo UI 2014 Q2 release, the Kendo UI widgets support AngularJS integration.

To activate the AngularJS directives, install the AngularJS library. Just like jQuery, the minified format of the AngularJS library is located is in the js directory of the downloaded Kendo UI bundle.

  • Unlike their dependency on jQuery, the Kendo UI distributions can function correctly without AngularJS.
  • To use AngularJS versions 1.5.x together with Kendo UI version R1 2017 or earlier is only recommended if you use the Kendo UI k-ng-model directive because the ng-model directive does not reflect the model value.

The following table provides a list of the AngularJS versions that are compatible with the major Kendo UI releases and their corresponding service packs.

Major Releases AngularJS Version Comments
Kendo UI 2019.1.115 (R1 2019) 1.4*, 1.5*, 1.6*, 1.7* -
Kendo UI 2018.3.911 (R3 2018) 1.4*, 1.5*, 1.6*, 1.7* -
Kendo UI 2018.2.516 (R2 2018) 1.4*, 1.5*, 1.6* -
Kendo UI 2018.1.117 (R1 2018) 1.4*, 1.5*, 1.6* -
Kendo UI 2017.3.913 (R3 2017) 1.4*, 1.5*, 1.6* -
Kendo UI 2017.2.504 (R2 2017) 1.4*, 1.5*, 1.6* -
Kendo UI 2017.1.118 (R1 2017) 1.4*, 1.5*, 1.6* -
Kendo UI 2016.3.914 (R3 2016) 1.4*, 1.5* Kendo UI provides limited ngModel support for AngularJS 1.5*.
Kendo UI 2016.2.504 (R2 2016) 1.4*, 1.5* Kendo UI provides limited ngModel support for AngularJS 1.5*.
Kendo UI 2016.1.112 (Q1 2016) 1.4*, 1.5* Kendo UI provides limited ngModel support for AngularJS 1.5*.
Kendo UI 2015.3.930 (Q3 2015) 1.4*, 1.5* Kendo UI provides limited ngModel support for AngularJS 1.5*.
Kendo UI 2015.2.624 (Q2 2015) 1.3.16 -
Kendo UI 2015.1.318 (Q1 2015) 1.3.0 -
Kendo UI 2014.3.1119 (Q3 2014) 1.3.0 -
Kendo UI 2014.2.716 (Q2 2014) 1.2.16 Upgraded to 1.2.21 in subsequent internal builds.

See Also

In this article
Not finding the help you need? Improve this article