Configuring Firefox for Test Studio Automation

As of the 2012 R2 release, the Calibrate Browsers feature can configure your browsers automatically, with the exception of enabling extensions (see below). If you need to resort to manual configuration, use the following settings. 



 


Enable Telerik Extensions

  1. Click Tools > Add-ons.
  2. Ensure that the Telerik Exploratory Testing Extension, Telerik Test Studio Recorder and Telerik Testing Framework extensions are enabled.


Zoom Level Set to 100%

  1. On the main menu click on View and then Zoom.
  2. Choose Reset (or use the keyboard shortcut: Ctrl + 0).

 

 

Turn Off Pop-up Blocker & Enable JavaScript

  1. On the main menu click on Tools and then Options. In version 4, click the orange Firefox menu in the upper left and then Options.
  2. Click on the Content tab.
  3. Uncheck the Block pop-up windows checkbox.
  4. Alternatively, if you would prefer to keep the pop-up blocker enabled, you can add all the addresses of your test websites to the Exceptions list. The problem with this approach is that any changes or any new test websites will need to be added to the list.
  5. Make sure Enable JavaScript is checked.

 

 

Pop-ups Open in a New Window

  1. Within the Options menu, click on the Tabs tab.
  2. Uncheck Open new windows in a new tab instead.  
  3. Click OK.

 

 

Open To a New Blank Page

  1. Within the Options menu, click on the General tab.
  2. Change the When Firefox starts selection to Show a blank page.

 

Enable File Downloads

  1. Within the Options menu, click on the "General" tab.
  2. Check Show the Downloads window...
  3. Uncheck Close it when all downloads are finished.
  4. Select Always ask me where to save files.

 

 

Enable Cookies

  1. Within the Options menu, click on the Privacy tab.
  2. Make sure that the History option is set to Remember history.

 


 

Disable 'Remember passwords for sites'

  1. Within the Options menu, click on the Security tab.
  2. Make sure the Remember Passwords for sites option is disabled.

    Remember passwords for sites setting disabled

Use System Proxy Settings

As of the 2012 R1 version released in April 2012, set the Connection Settings to Use system proxy settings.

  1. Within the Advanced menu, click on the Network tab.
  2. Click the Settings button in the Connection section.
  3. Click Use system proxy settings, then click OK.
  4.  

Disable Conflicting Extensions

The following Add-ons are known to conflict with the Telerik Testing Firefox Client:

  • AOL Messaging Toolbar
  • FoxyProxyStandard