Configuring Firefox for Test Studio Automation

As of the 2012 R2 release, the Calibrate Browsers feature can configure your browsers automatically. If you need to resort to manual configuration, use the following settings.

Enable Telerik Extensions

  1. Click Tools > Add-ons.
  2. Ensure that the Telerik Test Studio Automation and __Telerik Test Studio Recorder extensions are enabled.

Add-ons

Enable Telerik Extensions

  1. Click View > Zoom.
  2. Choose Reset (or use the keyboard shortcut: Ctrl + 0).

Zoom

Turn Off Pop-up Blocker & Enable JavaScript

  1. Click Tools > Options.
  2. Click on the Content tab.
  3. Uncheck the Block pop-up windows checkbox.

Pop-up blocker

Pop-ups Open in a New Window

  1. Click Tools > Options.
  2. Click on the Tabs tab.
  3. Uncheck Open new windows in a new tab instead.
  4. Click OK.

Pop-ups Open in a New Window

Open To a New Blank Page

  1. Click Tools > Options.
  2. Click on the General tab.
  3. Select Always ask me where to save files.

Downloads

Enable Cookies

  1. Click Tools > Options.
  2. Click on the Privacy tab.
  3. Make sure that the History option is set to Remember history.

Cookies

Disable 'Remember passwords for sites'

  1. Click Tools > Options.
  2. Click on the Security tab.
  3. Make sure the Remember Passwords for sites option is disabled.

Passwords

Use System Proxy Settings

As of the 2012 R1 version released in April 2012, set the Connection Settings to Use system proxy settings.

  1. Click Tools > Options.
  2. Click on the Advanced tab > Network tab.
  3. Click the Settings button in the Connection section.
  4. Click Use system proxy settings.

Proxy

Disable Conflicting Extensions

The following Add-ons are known to conflict with the Telerik Testing Firefox Client:

  • AOL Messaging Toolbar
  • FoxyProxyStandard