How to: Debug Telerik Data Access Application with IntelliTrace

Debugging with IntelliTrace, available in Microsoft Visual Studio 2010 and 2012 Ultimate, provides an enhanced picture of your application compared with traditional debuggers. Traditional debuggers show you the state of your application at the current time with limited information about events that occurred in the past. You must either infer events that occurred in the past, based on the state of your application at the current time, or restart the application to re-create past events. With IntelliTrace, you can actually see events that occurred in the past and the context in which they occurred. This reduces the number of restarts that are required to debug your application and the possibility that an error will fail to reproduce when you rerun the application.

IntelliTrace supports debugging only Visual Studio 2010 and 2012 applications (Visual Basic and C#).

This topic teaches you how to debug your Telerik Data Access application with IntelliTrace by using the following steps:

Enable and Disable IntelliTrace in Visual Studio

By default, IntelliTrace is enabled. Using the default settings, IntelliTrace has little effect on performance. Therefore, it is unlikely that you will ever need to turn it off. If you do need to turn it off, or turn it back on again, follow this procedure:

  1. On the Tools menu, click Options.
  2. In the Options dialog box, expand the IntelliTrace node and then click General.
  3. Select the Enable IntelliTrace check box.

  4. Click OK.

Show the IntelliTrace Window and Toolbar

The IntelliTrace toolbar is hidden by default. The IntelliTrace window is visible by default but can be hidden if you want to reduce clutter. By default, the IntelliTrace window appears in the same location as Solution Explorer and Team Explorer. You can hide the window by closing it using the standard close method.

To show the IntelliTrace window:

  1. On the Debug menu, point to IntelliTrace, and then click IntelliTrace Events or IntelliTrace Calls. This menu command is only available when are you are debugging.

To show or hide the IntelliTrace toolbar:

  1. On the View menu, point to Toolbars, and then click IntelliTrace.

Integrate IntelliTrace in Telerik Data Access Application

To integrate IntelliTrace in Telerik Data Access:

  1. On the Telerik menu, point to Telerik Data Access, and then click Options.
  2. In the Options dialog box and then click the IntelliTrace node.
  3. Click Enable.

  4. Click OK.

  5. You will need to restart your Visual Studio.
  6. On the Tools menu, click Options.
  7. In the Options dialog box, expand the IntelliTrace node and then click IntelliTrace Events. IntelliTrace events are collected when you run your application. You can enable or disable collection of IntelliTrace events by category or by specific event. In the IntelliTrace Events treeview locate and expand the Telerik Data Access category. It is probably the last node in the tree.

  8. Telerik Data Access allows you to trace the following events:

    1. Open Database
    2. Open Connection
    3. Close Connection
    4. Prepare
    5. ExecuteNonQuery
    6. ExecuteReader
    7. BeginTransaction
    8. CommitTransaction
    9. RollbackTransaction
    10. EnlistTransaction
    11. ExecuteScript
  9. Select all events you want to trace and click OK.