Ensure that the Proper Version of the .NET Framework is Installed

PROBLEM

Test Studio installation fails. You see the following line in the installation log:

 

SFXCA: Ensure that the proper version of the .NET Framework is installed, or that there is a matching supportedRuntime element in CustomAction.config

SOLUTION

The right .NET Framework needed to install and use Test Studio was not found on the machine. Please make sure Microsoft .NET framework 3.5.1 is properly installed.  If you're running Windows 7, ensure that Microsoft .NET framework 3.5.1 is installed and enabled:

 

Note: .NET 4.0 is required as of version 2012.1.411.