AppBuilder Stops Recognizing Your Connected iOS Device

This troubleshooting tutorial is intended for developers who need to connect iOS devices in the classic Windows desktop client or the extension for Visual Studio. You will learn:

  • How to remove device pairings
  • How to reset device pairings

Problem

You have successfully deployed apps on your iOS device with the classic Windows desktop client or the extension for Visual Studio. After you set up the device as a new device following a factory reset or a software update, the classic Windows desktop client or the extension for Visual Studio no longer recognizes the device as connected and you cannot deploy your app on the device.

When you connect the device to your system, the Devices pane shows the following message: No devices found. Make sure your device is connected to your computer.

Cause

When you connect an iOS device successfully for the first time, AppBuilder stores a pairing value for the device in your AppBuilder account. This pairing value matches an encryption key stored on the device. After you set up your device as a new device, this device encryption key is also reset and the pairing value in your AppBuilder account is no longer valid.

Solution

You need to remove the pairing for the device or to reset all device pairings from your account. This operation affects the selected device only.

See Also

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