The LiveSync Gesture No Longer Gets Changes

This troubleshooting tutorial is intended for developers who need to run apps on device. You will learn:

  • What might cause LiveSync to stop working
  • How to change the active build configuration
  • How to recreate an app

Problem

You have deployed your app on device and you have made some changes to your app. You can no longer synchronize your changes with the three-finger gesture.

Cause

The following issues might cause LiveSync to stop working with the three-finger gesture.

  • You have modified the app properties
  • Your active build configuration is set to Release
  • Your Cordova developer app installation is corrupted or not updated
  • Your QR code reader does not handle AppBuilder-generated QR codes properly
  • You have renamed the app
  • Your app is corrupted

Solution

Set the active build configuration

To be able to synchronize your changes, LiveSync needs to be enabled.

  1. Run AppBuilder and open the code for your app.
  2. Run the Build wizard.
  3. Select target platform and build target.
  4. Set the build configuration to Debug.
  5. Re-build your app.
  6. Re-deploy your app.

Re-deploy your app

Re-deploy your app to resolve the following issues.

  • You have modified the app properties
    LiveSync does not support synchronization for app properties.
  • You have renamed the app or the solution
    With the three-finger gesture or the Menu button, you attempt to get the latest changes from the AppBuilder Cloud Services by app name. When you rename your app or the solution, the app on the device is unaware of this change and can no longer access its corresponding app in the AppBuilder Cloud Services.

Reinstall the Cordova developer app

Sometimes, the Cordova developer app installation might become corrupted or might not be updated to the latest version. This might cause LiveSync to stop working properly. Reinstall the Cordova developer app and re-deploy your app.

Reinstall the QR code reader

Some QR code readers might not handle AppBuilder-generated QR codes properly. If you have used a third-party QR code scanner to load your app, try using the built-in QR code scanner.

  1. Run the developer app.
  2. With two fingers, tap and swipe the left edge of the screen to the right to show the application menu.
  3. Tap QR Scanner and use the built-in scanner to reload your app in the developer app.

Recreate your app

A corrupted app might prevent LiveSync from working properly. Recreate your app from archive and re-deploy your app.

See Also

Start a free trial Request a demo
Contact us: +1-888-365-2779
sales@telerik.com
Copyright © 2016-2017, Progress Software Corporation and/or its subsidiaries or affiliates. All rights reserved.