AppBuilder 3.7.4 Release Notes

Product version: AppBuilder 3.7.4

Released: May 12, 2017

AppBuilder 3.7.4 is an update release. For a list of the new features and updates introduced in the earlier major release, AppBuilder 3.7, see AppBuilder 3.7 Release Notes.

Major Features and Updates

Breaking Changes

Warning  In this version of AppBuilder, support for NativeScript 3.0.0 is experimental. Experimental framework versions have not been thoroughly verified. When you update your app to target NativeScript 3.0.0, you will experience multiple issues due to breaking changes in the APIs.
For more information about the major changes in NativeScript 3.0.0, see Cross-Platform Modules Changelog, Android Runtime Changelog.

Warning  Currently, NativeScript 3.0.0 apps can be developed only in the in-browser client and the command-line interface.

Warning  When you update your app to target NativeScript 3.0.0, you must open the .abignore file of your project and remove the **/*.ts, and tsconfig.json settings. You must ensure that all modules referenced in your app are updated to their latest versions. The NativeScript 3.0 Breaking Changes document contains information on how to resolve any additional issues that you might encounter.

Warning  The AppBuilder NativeScript templates and samples will not work with NativeScript 3.0.0 before you make all of the changes mentioned above.
To create a new NativeScript 3.0.0 app, use the Create from Sample functionality and choose the NS v3.0 TypeScript Angular sample.

Warning  NativeScript 3.0.0 apps are not backwards compatible with older NativeScript versions. Once you migrate your app to NativeScript 3.0.0, to migrate back to older NativeScript versions you must revert all changes.

Warning  Deprecated support for NativeScript 2.3.0 and 2.4.0. You can no longer change the target NativeScript version to 2.3.0 or 2.4.0. You will still be able to develop and build existing apps that target NativeScript 2.3.0 or 2.4.0. Support for NativeScript 2.3.0 and 2.4.0 will be removed in a future release.

Warning  Removed support for NativeScript 2.2.0. You can no longer build your app against NativeScript 2.2.0. To resolve the issue, migrate to a newer supported NativeScript version.

Start a free trial Request a demo
Contact us: +1-888-365-2779
sales@telerik.com
Copyright © 2016-2017, Progress Software Corporation and/or its subsidiaries or affiliates. All rights reserved.