Requirements of the UI Designer

The Kendo UI Designer is an experimental module with limited functionality. You can develop user interfaces only for hybrid applications that are initialized as Kendo UI applications.

Before attempting to develop user interfaces with the Kendo UI Designer, verify that your app meets the following requirements.

  • You are using the in-browser client, the classic Windows desktop client or the universal desktop client to develop your app.
  • You are developing a hybrid app (targeting Apache Cordova).
  • You have added the required Kendo UI Core or Kendo UI Professional libraries to your app.
    The Kendo UI Designer requires Kendo UI Core 2013.2.918 or later or Kendo UI Professional 2013.2.918 or later.
  • You have inserted references to the Kendo UI Core or Kendo UI Professional libraries in the HTML file that you want to edit with the designer tool. For example:

    <link href="kendo/css/kendo.mobile.all.min.css" rel="stylesheet" />
    <script src="kendo/js/kendo.mobile.min.js"></script>
    <script src="kendo/js/jquery.min.js"></script>
    

    If you use JavaScript loaders to load the libraries, the Kendo UI Designer might not be able to show your app properly.

  • The HTML file that you want to edit with the designer tool has a valid HTML5 markup.

  • You have initialized the mobile application in your app. For example:

    var app = new kendo.mobile.Application();
    

See Also

Start a free trial Request a demo
Contact us: +1-888-365-2779
sales@telerik.com
Copyright © 2016-2017, Progress Software Corporation and/or its subsidiaries or affiliates. All rights reserved.